Suche
Suche Menü

HowTo: Adobe Air 2.x unter Ubuntu 64Bit

Nachdem sich dieser Beitrag noch auf Adobe Air 1.5 bezieht, derweilen jedoch Adobe Air 2.x draussen ist, und die „alte“ Anleitung nicht mehr funktioniert, hier nun die Anleitung für die im Moment aktuelle Version:

Zunächst installieren wir die nötigen Pakete via

sudo apt-get install lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32z1 libc6 libc6-i386 lib32nss-mdns

Danach besorgen wir uns das Paket getlibs-all.deb z.B. von hier und installieren es:

sudo dpkg -i getlibs-all.deb

Danach besorgen wir uns über dieses Tool die nötigen 32Bit libs:

sudo getlibs -l libnss3.so.1d libnssutil3.so.1d libsmime3.so.1d libssl3.so.1d libnspr4.so.0d libplc4.so.0d \
libplds4.so.0d libgnome-keyring.so libgnome-keyring.so.0 libgnome-keyring.so.0.1.1

Abschliessend noch ein

sudo ldconfig

und einer Installation von Adobe Air sollte nichts mehr im Wege stehen…

Anmerkung für Linux Mint User

Wenn ihr unter Linux Mint bei dem Punkt sudo getlibs -l … folgende Meldung bekommt

dw@asgard ~ $ sudo getlibs -l libnss3.so.1d libnssutil3.so.1d libsmime3.so.1d libssl3.so.1d libnspr4.so.0d libplc4.so.0d \  libplds4.so.0d libgnome-keyring.so libgnome-keyring.so.0 libgnome-keyring.so.0.1.1
No match for libnss3.so.1d
No match for libnssutil3.so.1d
No match for libsmime3.so.1d
No match for libssl3.so.1d
No match for libnspr4.so.0d
No match for libplc4.so.0d
No match for libplds4.so.0d
No match for libgnome-keyring.so
No match for libgnome-keyring.so.0
No match for libgnome-keyring.so.0.1.1
No packages to install

müsst ihr den getlibs Befehlt etwas erweitern. Konkret solltet er dann bei euch wie folgt lauten:

sudo getlibs --distro Ubuntu --release lucid -l libnss3.so.1d libnssutil3.so.1d  libsmime3.so.1d libssl3.so.1d libnspr4.so.0d libplc4.so.0d \
libplds4.so.0d libgnome-keyring.so libgnome-keyring.so.0  libgnome-keyring.so.0.1.1

und schon werden auch bei euch die libs gefunden und installiert.

Update:

Um die ganze Sache etwas zu vereinfachen, hab ich die oben beschriebenen Schritte mal in einem Script zusammengefasst. Das Script und die Anleitung dazu gibts hier: https://akaul.de/download-tweetdeck-installations-skript-fur-ubuntu-10-04-64bit/

Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone

Autor:

Ich bin Andi, 34 Jahre jung, glücklicher Papa, Freizeit-Blogger, Pixelfänger und Pixelschubser. Ich hoffe der Artikel hat Dir gefallen. Über ein Feedback würd ich mich freuen :-) Du findest mich ausserdem bei Facebook, Twitter und Google+.

5 Kommentare Schreibe einen Kommentar

  1. Pingback: Adobe Air, Tweetdeck und Ubuntu 10.04 64Bit | blog.dunkelwesen.de

  2. Hab das automatisierte Skript mal benutzt, funktioniert eigentlic hagnz gut, aber zum Schluss bekam ich dann diese Meldung von Adobe Air:
    Die Anwendung konnte nicht installiert werden, da die Installationsdatei beschädigt ist. Bitten Sie den Anwendungsautor um eine neue Installationsdatei.
    ich schätze mal, ich muss da eifnach mal TweetDeck manuell runterladen^^

    Firefox 3.6.8 Ubuntu 10.04 x64

    Antworten

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.